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1 Tutorial Overview 
 

1.1 Introduction to OpenSim 
Models of the musculoskeletal system enable one to study neuromuscular coordination, analyze 

athletic performance, and estimate musculoskeletal loads.  OpenSim is freely available software 

that allows users to develop, analyze, and visualize models of the musculoskeletal system, and to 

generate dynamic simulations of movement.  In OpenSim, a musculoskeletal model consists of 

rigid body segments connected by joints.  Muscles span these joints and generate forces and 

movement [1].  Once a musculoskeletal model is created, OpenSim enables users to study the 

effects of musculoskeletal geometry, joint kinematics, and muscle-tendon properties on the 

forces and joint moments that the muscles can produce.  With OpenSim, our goal is to provide a 

framework that allows the biomechanics community to create, share, and extend a library of 

models and dynamic simulation tools. 

 

1.2 Tutorial Description 
Computer simulation has emerged as a powerful method to understand the dynamics of human 

movement and evaluate gait disorders in children with cerebral palsy. This course will provide a 

hands-on introduction to computer simulation that is accessible to clinicians of all backgrounds. 

Participants will learn about the capabilities and limitations of computer simulation and receive 

hands-on instruction about how to use OpenSim, a freely available software package for 

simulating movement. 

 

1.3 Audience 
Clinicians who want to learn how computer simulation can be used to answer clinical questions 

about gait. Participants will be asked to bring a laptop computer and will be given instructions 

on how to download and install OpenSim (a free software package) prior to the course.  

 

1.4 Learning Objectives 
A	
   team	
  of	
   computer	
   simulation	
  experts	
   from	
   the	
  National	
  Center	
   for	
  Simulation	
   in	
  Rehabilitation	
  

Research	
   (NCSRR)	
   at	
   Stanford	
   University	
   will	
   introduce	
   participants	
   to	
   the	
   basics	
   of	
   computer	
  

simulation	
   and	
   its	
   relevance	
   to	
   the	
   treatment	
   of	
   gait	
   pathology.	
   In	
   the	
   hands-­‐on	
   portion	
   of	
   the	
  

course,	
   participants	
  will	
   learn	
  how	
   to	
  use	
   the	
  OpenSim	
   software	
  package	
   to	
   estimate	
  hamstrings	
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lengths.	
   Additional	
   clinical	
   applications	
   of	
   OpenSim	
  will	
   also	
   be	
   described.	
   	
   The	
   specific	
   learning	
  

objectives	
  of	
  the	
  course	
  are:	
  

	
  
• Describe	
  a	
  musculoskeletal	
  model	
  and	
  its	
  component	
  parts	
  

• Load	
  a	
  model	
  in	
  OpenSim	
  and	
  animate	
  it	
  with	
  gait	
  kinematics	
  

• Plot	
  hamstrings	
  muscle-­‐tendon	
  lengths	
  over	
  the	
  gait	
  cycle	
  

• List	
  the	
  capabilities	
  and	
  limitations	
  of	
  computer	
  simulation	
  

	
  

1.5 Format 
Each section in this handout guides you through certain tools within OpenSim’s GUI and asks 

you to answer a few questions.  The menu titles and option names you must select and any 

commands you must type to run OpenSim will appear in bold face.  The questions can be 

answered based on information from OpenSim and basic knowledge of the human 

musculoskeletal system.  As you complete each section, feel free to explore OpenSim and the 

lower extremity model further on your own, with the “Reach” questions at the end of the section.   

 

1.6 Where to Find Additional Resources and Support 
There are many resources available to help with troubleshooting, access models and simulation 

data, and interact with the rest of the OpenSim community. 

1.6.1 The OpenSim GUI 

The OpenSim Help menu provides the following resources: 

• Direct links for filing a bug or requesting a new feature.  

• Direct links to three tutorials for becoming familiar with the OpenSim GUI.   

1.6.2 OpenSim User’s Guide 

The User’s Guide is an extensive resource for most of the features available in OpenSim. For 

assistance using the GUI and learning about setting up Tools in OpenSim, please refer to the 

OpenSim User’s Guide that is available under “OpenSim Documentation” at 

https://simtk.org/docman/?group_id=91. 
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1.6.3 Model and Simulation Repository 

You can create your own models of musculoskeletal structures and dynamic simulations of 

movement in OpenSim, as well as take advantage of computer models and dynamic simulations 

that other users have developed and shared. For example, you can use existing computer models 

of the human lower limb, upper limb, cervical spine, and whole body, which have already been 

developed and posted at https://simtk.org/home/nmblmodels. You can also use dynamic 

simulations of walking and other activities that have been developed, tested, and posted on 

SimTK.org. We encourage you to share your models and simulations with the research 

community by setting up a project on SimTK.org.  

1.6.4 Additional Online Resources 

There are many resources available online for support both during and after the workshop.  This 

includes the User’s Guide and model repository described above, as well as a user forum, 

tutorials, examples, webinars, and many other resources.  We’ve recently launched a new 

website that serves as a portal to these resources. It can be found at 

http://opensim.stanford.edu.   You can also find more about OpenSim and related projects by 

other researchers around that world at the SimTKorg project site at 

http://simtk.org/home/opensim.  

1.6.5 Publications 

You can find additional information in the following article: Delp, S.L., Anderson, F.C., Arnold, 

A. S., Loan, P., Habib, A., John, C., Guendelman, E.G., Thelen, D.G., OpenSim: Open-source 

software to create and analyze dynamic simulations of movement. IEEE Transactions on 

Biomedical Engineering, vol. 54, no. 11, pp. 1940-1950, 2007. Please cite this work in any of 

your own publications that use OpenSim. 
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1.7 OpenSim GUI Overview 
 

Title Screenshot

Toolbar

Model Drop Down Menu

Motion Text Box

Motion Slider / Video Controls

View Window

Navigator Window

Coordinates Window

Muscle Editor

GUI Components
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2  Musculoskeletal Model of 

the Lower Extremity 
In this section, you will load a model of the lower extremity [2] into OpenSim and make the 

model “walk.”  The model represents an adult subject with an approximate height of 1.8 m 

and an approximate mass of 75 kg.  The model consists of 13 rigid body segments and 

includes the lines of action of 86 muscles (43 per leg). 

 

2.1 Loading a Model 
The first model you will analyze is entitled Both Legs with Muscles.  To load this 

musculoskeletal model into OpenSim: 
 

• Click the File menu and select Open Model.   
 

• Find the examples folder, which is located under your OpenSim installation directory, 
e.g., C:\Program Files\OpenSim 1.0.   
Note: There are several different example models and motions in the examples folder.  All of 
the model and motion files used in the remainder of the tutorial will be located in this 
examples folder. 
 

• Open the BothLegs folder, select the file BothLegs.osim, and click Open. 
 

After loading a model, its name will appear in the model drop down menu, located in the 

toolbar, and in the Navigator window.  To see the Navigator window, which also provides 

specific information about the bodies, muscles, and joints in the model, click the Window 

menu and select Navigator.  To expand a Navigator heading, click the plus icon  to its left. 

Note: If already opened, you can also view the Navigator window by clicking its title bar. 

 

2.2 Viewing & Animating a Model 
OpenSim allows you to orient the model using your mouse. 

ROTATE  To rotate the view, click and hold the left mouse button and drag the mouse. 

TRANSLATE To translate the view, click and hold the center mouse button and drag the 

mouse. 
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ZOOM To zoom, click and hold the right mouse button.   

 To zoom in, drag the mouse down.  To zoom out, drag the mouse up. 
 

In addition to your mouse, there are six orienting icons located along the right side of the 

View window.  To view the model in the –X direction, click the      icon.  Similarly, click on 

the other icons to view along the other principal directions.  To see the axes of the world 

reference frame, click the axes icon      located on the right side of the View window. 

 

2.3 Coordinates 
The Coordinates window contains sliders that correspond to joint coordinates in the model.  

To see the Coordinates window, click the Window menu and select Coordinates.  For the 

current model, the orientation of the pelvis corresponds to the orientation of the model. 

Note: If already opened, you can also view the Coordinates window by clicking its title bar. 
 

• The first three sliders correspond to rotations of the pelvis about the Z, X, and Y-axes of 
the “world” reference frame.  To rotate the pelvis about the Z-axis, drag the rZ slider.  
Similarly, to rotate the pelvis about the other two axes, drag the corresponding slider. 
Note:  These rotations are different than rotating the model view.  
 

• The remaining sliders correspond to joint rotations and control a single degree of 
freedom.  To rotate the joints, drag the sliders or type in a desired joint angle in the 
adjacent textbox. 

 

• To save a pose, or a specific set of joint coordinates, for later use in the tutorial: 

- Restore the default joint coordinates by clicking the Poses button and selecting 
Default. 

- Flex the right hip 45º by typing 45 into the r_hip_flexion textbox and pressing 
Enter. 

- Click the Poses button, select New, type r hip flex 45 in the textbox, and click OK. 
 

2.4 Loading a Motion 
To animate the model, you need to load an associated motion file into OpenSim. 
 

• Click the File menu and select Load Motion.  Ensure you are in the BothLegs 
directory, select the file BothLegsWalk.mot, and click Open.  This motion file 
describes a normal gait. 
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After loading a motion, its name will appear in the motion textbox, 

located on the toolbar.  Additionally, a new branch will appear in 

the Navigator titled Motions.  Expand it to see all motions loaded 

for a particular model, as shown. 

 

2.5 Motion Slider  
The motion slider corresponds to the current motion file.  To make the model “walk”, drag 

the motion slider.  To animate the model, use the video control buttons, e.g., click play    .  

There are also buttons to loop       , pause     ,  and control the speed of the animation. 

 

2.6 Questions 
1. Degrees of Freedom 

a. Use the Coordinate slider to view the degrees of freedom of the model.  How many 
degrees of freedom does the model have?  List them. 

 
 
 
 

 

b. All models are approximations.  Compare the degrees of freedom in the model to the 
degrees of freedom in your lower limbs.  Which motions have been simplified?  
Which motions have not been modeled at all? 

 
 
 
 
 

 

2. Muscle Paths 
a. Muscle-tendon paths are represented in OpenSim by a series of points connected by 

line segments.  To see a list of all the muscles: 
 

• In the Navigator, expand the Actuators, Muscles, and all headings.  
 

• To display a single muscle, right-click on a specific muscle name under the all 
group, e.g., GMED1, and select Display > Show Only from the popup menu. 

 

• To toggle the display of all muscles, double-click on the Muscles or all 
heading. 

 Note: Double-clicking on a body, muscle group, or muscle heading in the Navigator 
toggles its display. 
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In this model, the gluteus medius is represented by multiple lines of action (e.g., 
GMED1, GMED2, GMED3).   
 
Name two other muscles in the model that are represented with multiple lines of 
action.  Why do you think these muscles are represented in this way? 
Hint: Other muscles with multiple lines of action use the same naming convention as the 
gluteus medius. 
 
 
 
 
 

 

b. For some muscles, two points, the muscle origin and insertion, are sufficient to 
describe the muscle path.  For other muscles that wrap over bones or are constrained 
by retinacula, intermediate wrapping or via points must be defined.  To view these 
wrapping points: 

 

• Zoom in on the right knee joint using the right mouse button. 
  

• Hide all other muscles except the r knee extensors muscle group:  Double click 
all muscles to hide all muscles, then double click on r knee extensors to only 
show this muscle group. 

  

• Fully flex the right knee using the r_knee_angle Coordinates slider.   
 

Notice that wrapping points are introduced in some of the knee extensors at certain 
knee angles, such that the muscles appear to wrap around the bones.   
 
Which knee extensor muscles have wrapping points?  At what knee angle do they 
occur? 
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2.7 Reach Exercises 
1. How many muscles are in the model?  Is this greater than the number of degrees of 

freedom?  What is the minimum number of muscles required to fully actuate the model?   
 Hint: Full actuation of the knee, for example, means both knee flexion and knee extension. 

 

 

 

 

 

2. Modeling Limitations 
Some muscles in the lower limb model pass through the bones or deeper muscles at 
extreme ranges of motion.  Zoom in on the right hip, and display only the GMAX3 
muscle (r hip extensors group).  Examine this muscle for the full range of hip flexion 
angles.   
 
Do you see any problems with GMAX3?  In what ways are point-to-point 
representations of muscle paths a simplification of musculoskeletal geometry? 
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3  Muscle-tendon Lengths, & 

Moment Arms 
In this section, you will investigate how muscle-tendon lengths and moment arms depend on 

limb configuration.  Musculoskeletal geometry is very important to the function of muscles 

and to the development of quantitative musculoskeletal models.  Muscle-tendon forces 

depend upon the muscle-tendon length, and joint moments depend upon both muscle-

tendon forces and moment arms.  Therefore, accurate specification of musculoskeletal 

geometry is essential in developing an accurate model for predicting muscle-tendon forces 

and joint moments. 

 

3.1 Using the Plotter 
OpenSim’s Plotter allows you to plot muscle-tendon properties, such as length, moment 

arm, force, and joint moment.  To generate a plot of fiber-length vs. knee angle for the 

rectus femoris and vastus intermedius muscles:   
 

• Return the model to its original pose by clicking Poses > Default in the Coordinates 
window. 
Note: Plots are created for the current configuration of the model.  Your plots will be made for 
the default pose. 

 

• To open a new plot, click the Tools menu and select Plot.  In the plotter window, click 
the  Y-Quantity button and select fiber-length.  This variable will appear on the y-
axis. 

 

• After selecting an appropriate Y-Quantity, you must select the muscles for which you 
want to generate curves.  Click on the Muscles button and a menu will appear. 

 

• To find muscles more quickly, you can filter the muscles by muscle group.  Choose the 
model option and use the group drop down menu to select r knee extensors.  The 
muscles list should now only show the muscles in the right knee extensors group.   

 

• Select rectus femoris and vastus intermedius from the list by clicking the checkboxes 
labeled RF and VASINT.   
Note: You do not have to close the muscles window as long as the plotter window is open, and 
your selections are immediately updated in the Muscles textbox.  This can be helpful when 
creating multiple curves on the same plot, which you will do in a few more steps. 
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• Click X-Quantity and select r_knee_angle.  This variable will appear on the x-axis. 
 

• To add a title to the plot, click the Properties button and type Fiber-Length vs. Knee 
Angle into the textbox under the Title tab.  Explore the plot properties, and then click 
OK. 

 

• To add the curves to the plot, click Add.   
Note: The plots use the following SI units: meters (length), Newtons (force), Newton-meters 
(moment).   

 

• Do not close the plot window, as you will be adding more curves in the next section. 
 

 

3.2 Questions 
4. Muscle Fiber Length vs. Joint Angle 

a. Study the plot of muscle fiber length vs. knee angle.  Do you think these curves would 
look different if, for example, the right hip was flexed? 

 
 
 
 
 

 

b. You will now flex the right hip by recalling the pose you previously saved: 
 

• In the Coordinates window, click Poses and select your saved pose (r hip flex 
45). 

 

• To add curves for 45º hip flexion using the same Quantities and Muscles, click 
Add. 

 Note: To print or save a plot, right-click on the plot and select Print or Export 
Image. 

 

Compare the two sets of curves you have just plotted.  How have the curves 
changed?  Can you explain your findings?  How can bi-articular muscles 
complicate analysis? 
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5. Muscle Moment Arm vs. Joint Angle 
Now plot knee extension moment arm vs. knee angle for the same two muscles: 

 

• Return the model to its original position by clicking Poses > Default. 
 

• To delete the previous curves, select all the names from the Curves List and click 
Delete. 
Note: To select multiple curve names, hold down ctrl while selecting. 

  

• Click Y-Quantity, select moment arm, and r_knee_angle. 
  

• To add a title to the plot, click the Properties button and type Moment Arm vs. 
Knee Angle into the textbox under the Title tab. 

 
• To add curves using the same Muscles and X-Quantity as previously selected, click 

Add. 
 Note: If you hover the cursor over a curve, a tool tip will give the coordinates at that 

particular point. 
  

Study the plot of knee extension moment arm vs. knee angle for rectus femoris and 
vastus intermedius.  At what knee angles do the moment arms peak?  What are the peak 
moment arms?  
 
 
 
 
 
 
 
You may notice that the moment arm curves have a discontinuity.  At what knee angle 
does the discontinuity occur?  What do you think causes this?  Hint: Look at Question 
2.b 
 
 
 
 
 
 
 
 

 

 

3.3 Reach  Exercises 
Feel free to make more plots for other limb positions, muscles, and/or joints.  When you are 

ready to continue with the tutorial, close the plotter window and close the Both Legs with 

Muscles model by clicking the File menu and selecting Close Model.  Do not save the 

model settings to file.  
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4 Assessment of Hamstrings 

Length During Crouch Gait 
In this final section of the tutorial, you will use OpenSim to investigate a possible cause of 

crouch gait, one of the most common walking abnormalities among individuals with cerebral 

palsy.  It is characterized by excessive flexion of the knee during stance phase, which is often 

accompanied by exaggerated flexion and internal rotation of the hip.  One hypothesized 

cause of crouch gait is short hamstrings, and orthopaedic surgeons will sometimes lengthen 

the hamstrings of such patients in an attempt to improve their posture and gait.  However, 

other causes of excessive knee flexion are possible (e.g. weak ankle plantarflexors), and 

lengthening the hamstrings can compromise the strength of these muscles [3].  How can a 

surgeon determine whether a hamstring lengthening procedure is warranted? 
 

One possible way to judge whether a patient’s hamstrings are shorter than “normal” is to 

develop a musculoskeletal model and compare the length of the hamstrings during the 

patient’s crouch gait cycle to the length of the hamstrings during a normal gait cycle.  

Suppose that an orthopaedic surgeon has brought you some kinematic data for a patient who 

walks with a crouch gait.  The surgeon is contemplating whether to operate, and wants your 

opinion. 
 

4.1 File Preparation 
Follow these steps to load the crouch gait and normal gait files: 
 

• Load the model file SeparateLegs.osim entitled Separate Legs with Muscles.  This 
model is located in the directory examples/SeparateLegs.  Separate Legs with 
Muscles is similar to Both Legs with Muscles, except that it has separate left and right 
pelvis segments that connect to the sacrum. 
Note: All of the tutorial models and motions are relative to your OpenSim installation 
directory, e.g., C:\Program Files\OpenSim 1.0.   

 

• To rename a loaded model, right-click on the model name in the Navigator and select 
Rename from the popup menu.  Type SepLegsCrouch into the textbox and click 
OK. 
Note: Renaming in this way does not affect the actual file name of the model. 
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• Load the motion file crouch1.mot, which is in the same folder as seplegs model.  This 
motion contains crouch gait data. 

 

• OpenSim has the ability to load multiple models simultaneously.  To open a second 
model, load the SeparateLegs.osim file again.   
Note: If you do not see both models after loading, press the r key. 

 

• To rename the second model, right-click on the current model name and select 
Rename.  Type SepLegsNormal into the textbox and click OK.   
Note: Throughout the rest of the tutorial, these two models will be referred to as crouch and 
normal. 
 

• You can adjust the position of the model in the viewer.  Right-click on the 
SepLegsNormal model in the Navigator window and select Display > Model 
Offset.  Set the X offset to 1 and click OK. 
 

 

The second model you loaded automatically becomes the current model.  Notice that the       

non-current model becomes translucent.  Any action, such as loading a motion, will be 

applied only to the current model. 
 

• Making sure that the normal model is still current, load the 
second motion file normal.mot.  This motion file contains 
normal gait data.   

 

• OpenSim can synchronize multiple motions, allowing you to 
animate multiple models simultaneously.  To do this, expand 
the Motions branch of each model in the Navigator, hold 
down ctrl, and select both motions names such that each 
name is highlighted.  Right-click on either motion name, 
then select Sync. Motions from the popup menu, as shown. 

 

 

4.2 Questions 
6. Range of Motion 

To animate the models and visually compare the crouch gait data to the normal gait data, 

click play.  Notice that both motions are synchronized, as shown.  Be sure to loop the 

animation, adjust the play speed, and rotate the models.  What differences do you 

observe? 
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Now quantitatively compare knee flexion angles over the crouch and normal gait cycles. 
 

• In a new plot, edit the text in the Curve Name textbox to read Normal Gait.   
 

• Click Y-Quantity, select normal_gait, and select r_knee_angle.  Click OK.   
 

• Click X-Quantity and select normal_gait.  Click OK. 
 

• To add the curve of right knee angle vs. gait cycle, click Add. 
 

• Make the crouch model current by right-clicking on the SepLegsCrouch model in 
the Navigator window and selecting Make Current. 

 

• In the Curve Name textbox edit the text to read Crouch Gait, then click Add.   
 

• In the same plotter window, click Y-Quantity, select crouch1_gait, and select 
r_knee_angle.  Click OK.   

  

• Click X-Quantity and select crouch1_gait.  Click OK.   
  

Can you identify the intervals at which heel strike, stance, toe off, and swing phase 
occur for a “normal” gait cycle?  Sketch a plot of the curve, and label the intervals.   
 
 
 
 
 
 
 
 
 
 
What is the “normal” range of knee flexion during stance phase?  How does this knee 
flexion curve for crouch gait compare to the normal gait data?   
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7. Hamstrings Length 
To address the surgeon’s question, compare the hamstrings length over the crouch gait cycle 

to the hamstrings length over the “normal” gait cycle. 
 

• To delete the previous curves, select all the names from the Curves List and click 
Delete. 
Note: To select multiple curve names, hold down ctrl while selecting. 
 

• Make the normal model current by selecting it through the Navigator pane. 
  

• In the Curve Name textbox edit the text to read Normal Gait.   
• Click Y-Quantity and select muscle-tendon length. 
  

• Click on Muscles and select Hamstrings from the list.  Click Close. 
Note: To quickly find the Hamstrings, type ham into the pattern textbox. 

  

• Click X-Quantity and select normal_gait. 
  

• To add the curve of hamstrings length vs. gait cycle, click Add. 
  

• To make a similar curve for the crouch gait data, make the crouch model current.  In 
the Curve Name textbox, edit the name to read Crouch Gait Then, click on Y-
Quantity and re-select muscle-tendon length.  

  

• Click on Muscles and select Hamstrings. 
 

• Click X-Quantity and select crouch1_gait and then click Add. 
 

Study the curves.  Based on the plot, what recommendation would you give the surgeon?  
Can you think of any limitations of your analysis? 
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4.3 Reach Exercises 
The orthopaedic surgeon cares for three other patients who walk with a crouch gait.  Repeat 

the above analysis for motion files crouch2.mot, crouch3.mot, and crouch4.mot.  Note that 

you can associate more than one motion with a model.  Would your recommendations to the 

surgeon be any different for these patients?  If you would like to learn more about this type 

of analysis, please read reference [3]. 
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